Wikia

Vim Tips Wiki

Changes: Building Vim

Edit

Back to page

(Comments: update todo with done tasks)
(Building Vim on Ubuntu)
 
Line 27: Line 27:
 
libgtk2.0-dev libatk1.0-dev libbonoboui2-dev \
 
libgtk2.0-dev libatk1.0-dev libbonoboui2-dev \
 
libcairo2-dev libx11-dev libxpm-dev libxt-dev
 
libcairo2-dev libx11-dev libxpm-dev libxt-dev
  +
</pre>
  +
  +
For ruby support, you need for package ruby-dev:
  +
<pre>
  +
sudo apt-get install ruby-dev
 
</pre>
 
</pre>
   

Latest revision as of 22:35, March 29, 2014

Tip 376 Printable Monobook Previous Next

created 2002 · complexity basic · version 7.0


This tip presents an overview of how to download the source for Vim, then build a Vim executable, and install it on your system. You need to download the C source code and the runtime files (standard plugins, help files, and more). You may also need to download dependencies (packages required for building), and you will need a compiler/linker (free versions are available for almost all systems). See where to download Vim if you want to download the Vim program to run on your system, without building it yourself.

Any platformEdit

It is easy to build Vim from the source code. In general, it takes four steps:

  1. Get dependencies. On Unix-like systems, apt-get build-dep vim-gnome or similar can do this for you. On Windows, there are no dependencies, unless you want to build Vim to use an external DLL for Lua, Perl, Python, Ruby, or Scheme (and you can install these later).
    Note: apt-get is for Debian, Ubuntu and similar distributions. On other distributions, the corresponding program may be called yum, yast, zypper, or otherwise, and the way to invoke it may vary widely. It is usually the same program as the one used on your distro to install, update, or uninstall any software package, and if you are lucky, there may be a manpage for it.
  2. Get the Vim source code from Mercurial or a GitHub clone.
  3. Change to the directory with the Vim source code and run "make".
  4. Do a "make install" or manually copy necessary files to somewhere Vim knows to use. See :help $VIMRUNTIME for details and our tip on manually locating your Vim files.

Building Vim on UbuntuEdit

You need the required development packages on Ubuntu to build the GUI:

sudo apt-get install libncurses5-dev libgnome2-dev libgnomeui-dev \
  libgtk2.0-dev libatk1.0-dev libbonoboui2-dev \
  libcairo2-dev libx11-dev libxpm-dev libxt-dev

For ruby support, you need for package ruby-dev:

sudo apt-get install ruby-dev

Commands to build and install GUI Vim:

$ cd vim7
$ cd src
$ make distclean
$ ./configure --with-features=huge --enable-gui=gnome2
$ make
$ sudo make install

Building Vim .debs on Ubuntu/DebianEdit

Commands to get started and build the first time.

$ sudo apt-get install mercurial libssl-dev
$ sudo apt-get build-dep vim
$ hg clone http://hg.debian.org/hg/pkg-vim/vim
$ cd vim
$ hg checkout unstable
$ debian/rules update-orig
$ dpkg-buildpackage -i -I
$ cd ..

And to update Vim .debs

$ cd vim
$ hg pull
$ hg update
$ debian/rules update-orig
$ dpkg-buildpackage -i -I
$ cd ..

Building Vim on WindowsEdit

There are a couple options for a compiler on Windows. Vim ships with makefiles for Cygwin, MinGW, and Visual Studio. Visual Studio express is free to download and use from Microsoft and should work with the supplied makefile.

In general, you will invoke a make program and pass in the desired build options, like:

make FEATURES=HUGE GUI=yes gvim.exe

Some more details and examples here:

After you've built Vim, run the compiled executable and do :version to verify it built as you intended. Then you're ready to install; close the Vim instance before you continue.

One option is to just install manually every time without any nice installer options like having .bat files in your system path to launch Vim from the command line, a default _vimrc, shell context-menu "Edit with Vim" item, etc.:

But most of the time you want to install Vim somewhere everybody on the computer can use it, and integrate it as if you installed from Bram's binary.

To do this, see the details in the INSTALLpc.txt file in the src directory of the code you downloaded. Basically it all boils down to:

  1. Create a directory like C:\Program Files\vim\vim74 or C:\Vim\vim74
  2. Copy all .exe files from src (which you compiled) to that vim74 directory.
  3. Copy xxd.exe from src/xxd into vim74
  4. Copy the .dll file from src/GvimExt into vim74
  5. Copy all files and folders from the runtime directory in your downloaded source into that vim74 directory
  6. Run a cmd.exe prompt as administrator (i.e. right-click and choose "run as administrator" to give yourself admin rights in UAC).
  7. Go to the vim74 directory and run the install.exe file you copied over in step (2).

This will put Vim into a spot everybody can use it, and give you options to create default _vimrc, user config areas, .bat files for command-line use, "edit with Vim" context menu, etc.

MiscellaneousEdit

In Vim, the command :version includes "Compiled by user@host" (the user and computer host names are provided by the operating system).

The configuration option --with-compiledby can be used to set the exact "Compiled by" text (for example, to include an email address).

Using patchesEdit

Following works but is obsolete; see above for information on using Mercurial.
The following applies to Unix-based systems, and Windows.

Download the source from ftp://ftp.vim.org/pub/vim/unix/

  • vim-7.2.tar.bz2 (7.1MB)

Download the extras from ftp://ftp.vim.org/pub/vim/extra/

  • vim-7.2-extra.tar.gz (0.8MB)
  • vim-7.2-lang.tar.gz (1.4MB)

Expand each in the same directory, for example somewhere/vim/build/72/

Download the patches from ftp://ftp.vim.org/pub/vim/patches/7.2/

Apply the patches.

Configure.

Build (compile and link).

Install.

See alsoEdit

Tips, some of which need updating

External sites with how-to information on building Vim

CommentsEdit

 TO DO 

  • Where to get other stuff included in the standard installation, like diff.exe.

Merge or link to some of these?

The only tip with info on diff.exe is:


Make sure the library names are correct for all or most distributions. In the Linux dist I'm using it seems the libraries are named <X>-devel instead of <X>-dev. Michael Greene 15:50 Feb 27, 2011 (UTC)

Around Wikia's network

Random Wiki