Wikia

Vim Tips Wiki

Script:3475

Talk0
1,610pages on
this wiki
Revision as of 09:51, July 14, 2012 by JohnBot (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Use this page to discuss script 3475 Vim Blog: post to Wordpress from Vim

  • Add constructive comments, bug reports, or discuss improvements (see the guideline).
  • Do not document the script here (the author should do that on vim.org).
  • This page may be out of date: check the script's vim.org page above, and its release notes.

CommentsEdit

  • Josh Kenzer March 10, 2011 - Just uploaded a new version.
  • It should be mentioned that Python is required for this script to work. (I added this note to the description: jkenzer)
  • Does not work on Windows (At least I couldn't make it work after installing Python32)

Keith Pickett 13:35, March 2, 2011 (UTC)

  • It cannot fetch the content after More Tag. For example, my new blog post HTML source code is
    content1 content2
    , and after insert More Tag in it, it becomes
     content1 <!--more--> content 2 
    . Using ":BlogOpen id " command can fetch the entire content in first situation, and only fetch "content1" in second situation.
    • JKenzer - I don't use the more tag when blogging. I will look in to this though and see if I can get it working for you.

Configuring Vim Blog to Work With win32Edit

As it turns out, this works great on win32! Here is what I did to make it work:

  1. Download Python 2.6 for Windows from here: Python 2.6.6 for Windows
  2. Download http://www.gooli.org/blog/gvim-72-with-python-2526-support-windows-binaries/ Gvim 7.2 with Python 2.5/2.6 support Windows binaries (unknown website: see note below)
  3. Follow the instructions for installing the Gvim with Python2.5/2.6. It is assumed you already have the original Vim 7.2 installed. All this does is replace the vim.exe and gvim.exe files.
  4. Modify your PATH Environmental variable to add the Python 2.6 install directory. The default install for Python (2.6.6 in our example) is c:\Python26. Append this to the end of the directory stack.

You should now be able to use the script.

As a separate note, I noticed my version of Gvim has support for Python 2.4 compiled in. So, you may be able to use the default install of Gvim as it is provided you can find and install Python 2.4 and set up your PATH environment variable to reflect the setup. Keith Pickett 22:14, March 4, 2011 (UTC)

We should not recommend that people download executables from unknown websites, particularly when the executable is something as complex and important as Vim. See Download for a range of options that are well known to the Vim community. The Vim without Cream option has lots of old versions of Vim for Windows, many of which will support Python 2.6. Unfortunately, Sourceforge has fubared their website again, and I'm finding it difficult to read the release notes associated with each download. Nevertheless, if we are going to recommend a download, it should be from there.
I just worked out how to view the release notes for Vim 7.3.135 (has both Vim and gvim for Windows), and it supports Python 2.6. Therefore, there is no need to install an obsolete version of Vim (7.2 is obsolete) just to run Vim with Python 2.6. Is there a reason to not use the latest version of Vim? JohnBeckett 03:53, March 5, 2011 (UTC)
I use Vim 7.2 on Windows with lots of customized scripts and I don't won't to upgrade. I'm tired of fighting release compatibility problems. I also do not have the time to test various scenarios and configurations involving release versions. My version has Py 2.4 support compiled in, hence my need to seek alternative versions with higher Py revision support. I will post my solutions on my blog in the future and leave it to Google for anyone looking for a solution. Your suggestions are noted and i'm done with this. Keith Pickett 06:38, March 5, 2011 (UTC)
It's easy to compile your own Python-enabled gvim.exe and vim.exe on Windows, see my tip: http://vim.wikia.com/wiki/Build_Python-enabled_Vim_on_Windows_with_MinGW . As a user, not a developer by profession, I sympathize with you when you say you are tired of fighting release compatibility problems. However, Vim's development is quite conservative. There are no compatibility problems between 7.3 and 7.2 whatsoever. And there are a lot of bugs fixed, e.g., some serious folding-related bugs. Vlad.irnov 21:21, March 5, 2011 (UTC)
The gooli.org page has been around for a while, it can be trusted. There is no need to ban it, just warn users that these are not official Vim binaries, use them at our own risk. Vlad.irnov 21:21, March 5, 2011 (UTC)
I accept what you say, but I do not recall hearing about that site at any of the Vim mailing lists. Further, the gooli page is static and is unlikely to be updated, whereas the Vim without Cream site is updated regularly and has a large number of old versions (so if someone has a need to operate an old version of Vim, they can). I could not see any mention of what patch level is contained in the Vim 7.2 download at gooli. The semi-official Vim without Cream page has close-to-current Vim (7.3.135 2011-02-25) as well as 7.2 versions from 7.2.2 2008-08-22 to 7.2.446 2010-07-15.
7.2.2 means Vim version 7.2 with patches 1-2 included. That is from August 2008, a long time ago in terms of software updates: 7.2.446 includes patches 1-446. I checked that the 7.3.135 version supports Python 2.6, so it is likely that most earlier versions also do that, back to a couple of months after when Python 2.6 was released. JohnBeckett 07:35, March 6, 2011 (UTC)

Around Wikia's network

Random Wiki