Wikia

Vim Tips Wiki

Changes: Where to download Vim

Edit

Back to page

(Change <tt> to <code>, perhaps also minor tweak.)
m (Reverted edits by 91.11.30.126 (talk | block) to last version by Vlad.irnov)
 
(32 intermediate revisions by 14 users not shown)
Line 29: Line 29:
 
*:See [[#Vim without Cream problems|"Vim without Cream problems" below]].
 
*:See [[#Vim without Cream problems|"Vim without Cream problems" below]].
 
*I'm using 64-bit Windows.
 
*I'm using 64-bit Windows.
:*You can ''probably'' use the '''''Vim without Cream''''' install mentioned above. The Cream build is better tested and supported than current 64-bit distributions. However, there are a few reasons why you may desire a Vim compiled for 64-bit support:
+
:*You can ''probably'' use the '''''Vim without Cream''''' install mentioned above. The Cream build is better tested and supported than current 64-bit distributions.
::# Editing files >4GB in size.
+
:*Multiple individuals have published 64-bit builds compiled from the official [http://code.google.com/p/vim/ Vim Mercurial repository] (in no particular order):
::# 64-bit WinPE does not have a WOW64 subsystem, hence you cannot run a 32-bit executable.
+
::*http://bintray.com/veegee/generic/vim_x64, including 64-bit python 2.7 and 3.3 support, and lua 5.2 support
::# Windows Server 2008 R2 (i.e. Win7 Server) also does not have the WOW64 subsystem, by default, although it is an optional component you can install.
+
::* http://tuxproject.de/projects/vim , supports both x86 (32-bit) and x64 (64-bit) architectures, compiled with Xpm and DirectX support, provides "huge" feature set and scripting interfaces for Tcl, Python 2, Python 3, Ruby, Lua (x86 only), and Perl
::# Potential for performance gains, particularly in heavy memory operations like memcpy and memcmp which can be optimized for the 64-bit word size.
+
::* https://bitbucket.org/Haroogan/vim-for-windows , supports both x86 (32-bit) and x64 (64-bit) architectures, provides "huge" feature set and scripting interfaces for latest Python 2, Python 3, Ruby, Lua, and Perl
:*See [http://code.google.com/p/vim-win3264/wiki/Win64Binaries information and download].
+
::*'''(outdated)''' http://code.google.com/p/vim-win3264/wiki/Win64Binaries
  +
:While the 32-bit Vim should suffice for most users as mentioned, there are a few reasons why a 64-bit Vim is preferable to a 32-bit version on 64-bit systems:
  +
:# Editing files >4GB in size.
  +
:# 64-bit WinPE does not have a WOW64 subsystem, hence you cannot run a 32-bit executable.
  +
:# Windows Server 2008 R2 (i.e. Win7 Server) also does not have the WOW64 subsystem, by default, although it is an optional component you can install.
  +
:# Potential for performance gains, particularly in heavy memory operations like memcpy and memcmp which can be optimized for the 64-bit word size.
  +
:#Getting 32-bit Vim into a 64-bit "Edit with Vim" context menu entry is tricky.
 
*I want standard Vim (source code to compile for all platforms, or unpatched Windows executables).
 
*I want standard Vim (source code to compile for all platforms, or unpatched Windows executables).
 
*:Available at http://www.vim.org/download.php
 
*:Available at http://www.vim.org/download.php
Line 52: Line 52:
   
 
==Linux/Unix==
 
==Linux/Unix==
Your distribution's package manager probably includes a package for installing Vim, but it is often very out of date. Be sure to look for "vim-huge", "vim-gnome", "vim-full", or similar if you want to go this route.
+
Linux distributions by default often include a stripped-down version of Vim without scripting or GUI (aliased to command vi or vim). Use your distribution's package manager to install the full-featured Vim version. The relevant package names are usually in the form vim-* .
   
Rather than downloading a Vim executable, you may get a better result by downloading the source and building your own because it is very easy to [[Building Vim|build your own Vim]].
+
For Debian and Ubuntu-based Linux distributions:
  +
:<code># apt-get install vim-gtk</code>
  +
For Fedora:
  +
:<code># yum install vim-enhanced vim-X11</code>
  +
  +
Beware that installing distribution's Vim package usually adds a system-wide customization of Vim via .vimrc, .gvimrc, .virc, etc. You may want to examine locations of system .vimrc files in the output of <code>:version</code> and to check what gets sourced on Vim startup with <code>:scriptnames</code>. In case of Debian vim-gtk package, the system-wide customization starts in /etc/vim/ and the actual settings are in /usr/share/vim/vim74/debian.vim or similar.
  +
  +
Your distribution's package for installing Vim may be very out of date, or it may not have the right Vim features. You may get a better result by downloading the source and building your own Vim because it is very easy to [[Building Vim|build your own Vim]].
   
 
==Comments==
 
==Comments==

Latest revision as of 19:26, December 1, 2014

Tip 1578 Printable Monobook Previous Next

created 2008 · complexity basic · author Metacosm · version 7.0


This tip outlines some recommended procedures for downloading a Vim executable (that is, a program you can run). Alternatively, you can download the Vim source and build your own Vim.

WindowsEdit

Which version of Vim should I use?

  • I want a fully patched standard Vim for Windows, without compiling it myself.
    Get Vim without Cream: The easiest and best solution for Windows users on 32-bit systems is to use the standard Vim at http://sourceforge.net/projects/cream/files/
    Under "Newest Files" near the top of the list, there should be a file with a name like gvim-7-3-3.exe
    (Vim without Cream, version 7.3.3 = 7.3 with patches 1–3).
    The release notes are also available; they show the output of the Vim :version
    command which includes what features are in the build.
    Click the most recent gvim-7-3-xxx.exe to download.
    Run the downloaded installer and accept the license agreement.
    On the Choose Components window, expand "Icons, menus and shortcuts".
    If you want an "Edit with Vim" item in Explorer's right-click menu, check the box for "Add Contextual Menu".
    Finish the install.
    It installs a patched standard gvim.exe (GUI) and vim.exe (console), with all help and runtime files.
    All installed files are "standard" Vim (the installers named cream-xxx.exe are for a special "Vim with Cream" version).
    Includes interfaces for Lua, MzScheme, Perl, Python, Tcl. Ruby 1.8 support was included up until version 7.3.289. More recent versions no longer include Ruby support.
    See "Vim without Cream problems" below.
  • I'm using 64-bit Windows.
  • You can probably use the Vim without Cream install mentioned above. The Cream build is better tested and supported than current 64-bit distributions.
  • Multiple individuals have published 64-bit builds compiled from the official Vim Mercurial repository (in no particular order):
While the 32-bit Vim should suffice for most users as mentioned, there are a few reasons why a 64-bit Vim is preferable to a 32-bit version on 64-bit systems:
  1. Editing files >4GB in size.
  2. 64-bit WinPE does not have a WOW64 subsystem, hence you cannot run a 32-bit executable.
  3. Windows Server 2008 R2 (i.e. Win7 Server) also does not have the WOW64 subsystem, by default, although it is an optional component you can install.
  4. Potential for performance gains, particularly in heavy memory operations like memcpy and memcmp which can be optimized for the 64-bit word size.
  5. Getting 32-bit Vim into a 64-bit "Edit with Vim" context menu entry is tricky.
  • I want standard Vim (source code to compile for all platforms, or unpatched Windows executables).
    Available at http://www.vim.org/download.php
  • I want an easy-to-use configuration for Windows with common menus and standard keyboard shortcuts.
    Cream for BSD, Linux and Windows is available at http://cream.sourceforge.net/download.html
    Click "Windows ... One-click installer, includes both Vim and Cream".
    You will download a file with a name like cream-0-42-gvim-7-2-245.exe
    (Cream version 0.42 with gvim version 7.2.245 = 7.2 with patches 1–245).

Vim without Cream problemsEdit

"Vim without Cream", as described above, is the best Vim for 32-bit Windows (without compiling it yourself). This section documents known problems.

  • The release notes show that it is built with feature +ole which means that it will try to load the OLE interface DLL each time it starts, which would be irritating if you just wanted to run Vim on another computer without bothering to install Vim.
  • The format of the Sourceforge page occasionally changes and the instructions given above may not exactly match what you see. For standard Vim and gvim without Cream, look for the highest version of the gvim-7-3-xxx.exe file.
  • In the past, the Sourceforge page required that scripting be enabled in your browser, and, near the bottom of the file list, you had to click "+" next to "Vim" to expand the list of files.

MacintoshEdit

See the versions at http://www.vim.org/download.php#mac

Linux/UnixEdit

Linux distributions by default often include a stripped-down version of Vim without scripting or GUI (aliased to command vi or vim). Use your distribution's package manager to install the full-featured Vim version. The relevant package names are usually in the form vim-* .

For Debian and Ubuntu-based Linux distributions:

# apt-get install vim-gtk

For Fedora:

# yum install vim-enhanced vim-X11

Beware that installing distribution's Vim package usually adds a system-wide customization of Vim via .vimrc, .gvimrc, .virc, etc. You may want to examine locations of system .vimrc files in the output of :version and to check what gets sourced on Vim startup with :scriptnames. In case of Debian vim-gtk package, the system-wide customization starts in /etc/vim/ and the actual settings are in /usr/share/vim/vim74/debian.vim or similar.

Your distribution's package for installing Vim may be very out of date, or it may not have the right Vim features. You may get a better result by downloading the source and building your own Vim because it is very easy to build your own Vim.

CommentsEdit

Around Wikia's network

Random Wiki